Twilio is down
Incident Report for Retreaver
Resolved
Twilio is back up. Calls are completing successfully. Some calls in Retreaver may appear to be hanging but will resolve within 4 hours and will not be billed.
Posted 11 months ago. Mar 10, 2018 - 22:07 EST
Monitoring
Our phone service provider, Twilio, is currently down. New calls are unable to complete. We have been monitoring the situation closely and will provide updates soon.
Posted 11 months ago. Mar 10, 2018 - 21:53 EST