Issue with some incoming voice calls
Incident Report for Retreaver
Resolved
Twilio's REST API appears to be responding again and operations have returned to normal. Some calls may appear to be hanging in Retreaver when they have actually finished, these calls will close out automatically and be finalized shortly. We're sorry for the issue, and we're continuing to monitor the situation as the night progresses.
Posted about 1 month ago. Nov 12, 2018 - 21:29 EST
Identified
Twilio's REST API is down. We first noticed elevated errors from the Twilio API at 8:46 pm EST. We're currently monitoring the issue. Not all calls are affected. We sincerely apologize to our customers for the impact.
Posted about 1 month ago. Nov 12, 2018 - 21:14 EST
This incident affected: Call Handling and Twilio Incoming Phone Calls.