Some inbound calls to local numbers are currently failing
Incident Report for Retreaver
Resolved
Calls are coming through again on affected numbers. We regret the occurrence and will be moving our remaining local numbers off Twilio very soon.
Posted 8 months ago. Mar 14, 2018 - 18:14 EDT
Monitoring
Our carrier, Twilio, is currently investigating an issue with some North American phone numbers. We are monitoring the situation and will provide updates soon. Toll-free numbers, and recently provisioned local numbers, are working.
Posted 8 months ago. Mar 14, 2018 - 17:29 EDT