Collaborators can't see phone numbers
Incident Report for Retreaver
Resolved
We've solved the issue.
Posted about 3 years ago. Sep 20, 2015 - 19:48 EDT
Identified
We're aware of an issue preventing collaborators from seeing phone numbers in their account. We're preparing a fix for the issue that will be live shortly.
Posted about 3 years ago. Sep 20, 2015 - 19:14 EDT