Payment problems.
Incident Report for Retreaver
Resolved
Hooray! Stripe has resolved their issue and everyone is caught up.
Posted about 3 years ago. Oct 07, 2015 - 22:14 EDT
Monitoring
Apparently Stripe, our credit card processor, is down. We've decided that since they're down everyone (existing accounts that aren't banned, TYVM) can have free reign of the system and we'll try charging all your cards again once they're back up. Sorry for the inconvenience.
Posted about 3 years ago. Oct 07, 2015 - 21:28 EDT