RTB performance is degraded

Incident Report for Retreaver

Resolved

RTB service has been stable for the past 2hrs, marking as resolved.
Posted Jul 13, 2026 - 15:28 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 13, 2026 - 14:02 EDT

Monitoring

Service to RTB is improving and we are continuing to monitor it.
Posted Jul 13, 2026 - 13:29 EDT

Update

Our engineering team is continuing to work on restoring RTB to full performance.
Posted Jul 13, 2026 - 13:06 EDT

Identified

We are investigating an issue with our RTB servers.
Posted Jul 13, 2026 - 12:38 EDT
This incident affected: Real Time Bidding.