Investigating some RTB calls not showing up in reporting

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 14:53 EDT

Update

RTB log has caught and all the requests are shown
Posted Jul 31, 2025 - 14:52 EDT

Investigating

We are aware of some RTBs not showing up in our RTB Log reporting section. These RTBs are still operational and our engineers are working on resolving the issue so they appear properly in the Log section.
Posted Jul 31, 2025 - 14:09 EDT
This incident affected: Reporting.