Partial outage resulting in delays accessing the web site have been resolved, we are continuing to monitor
Incident Report for Retreaver
Resolved
Issue is resolved, we are continuing to monitor live call numbers.
Posted Nov 02, 2023 - 11:14 EDT
Monitoring
Status changed from investigating -> monitoring
Posted Nov 02, 2023 - 10:55 EDT
Update
We are continuing to monitor.
Posted Nov 02, 2023 - 10:45 EDT
Update
Some users may have experienced delays when loading the user interface. This is no longer occurring and we will continue to closely monitor it.
Posted Nov 02, 2023 - 10:43 EDT
Update
Calls are operational, we will continue to monitor for issues
Posted Nov 02, 2023 - 10:35 EDT
Investigating
We are currently investigating this issue.
Posted Nov 02, 2023 - 10:28 EDT
This incident affected: Site/Account Portal.