Detected an increase in errors on web portal

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 11:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 20:06 EDT

Update

Website access has now been restored, we will keep monitoring for any further issues
Posted Sep 02, 2025 - 20:00 EDT

Update

We detected another spike in errors for a subset of visitors to our website. Our team is investigating.
Posted Sep 02, 2025 - 19:44 EDT

Identified

We've identified an issue impacting a very limited set of users. A solution is being implemented. If you come across an error message when accessing our web portal and it's a showstopper, please get in touch with us and we'll find a way to help.
Posted Sep 02, 2025 - 13:39 EDT

Investigating

You may occasionally see an error message with “We’re sorry, something went wrong.”

We will be deploying a fix shortly.
Posted Sep 02, 2025 - 11:23 EDT
This incident affected: Site/Account Portal.