There's an issue with Call Handling at Twilio
Incident Report for Retreaver
Resolved
Twilio has issued the all clear, and systems seem to be operating normally. We haven't seen any additional errors in the past hour. We sincerely regret the impact of this issue on our customers.
Posted 10 months ago. Nov 05, 2018 - 15:24 EST
Update
We're continuing to see small, intermittent bursts of errors from our telephony provider, Twilio (from 1:51 to 1:54 pm EST). This outage is affecting their entire platform. We're continuing to monitor the situation and sincerely apologize to our customers for the issue.
Posted 10 months ago. Nov 05, 2018 - 13:58 EST
Update
This morning and afternoon, our telephony provider, Twilio, experienced degraded service in 3 separate periods, from 10:58 AM until 11:54 AM (EST), 12:15 PM - 12:40 PM, and 1:00 PM - 1:04 PM. During this time, some calls were negatively impacted, resulting in error messages being played to the caller. We're continuing to monitor the situation and will provide further updates soon.
Posted 10 months ago. Nov 05, 2018 - 13:15 EST
Update
We're seeing errors again. Some calls may intermittently fail as we wait for Twilio to get their services under control. Our apologies to our users for this.
Posted 10 months ago. Nov 05, 2018 - 13:06 EST
Update
Twilio is reporting that the issue has been identified and their services have recovered. We're continuing to monitor for issues.
Posted 10 months ago. Nov 05, 2018 - 12:50 EST
Update
We haven't seen any errors in the past 5 minutes. We're continuing to monitor the situation.
Posted 10 months ago. Nov 05, 2018 - 12:44 EST
Update
Twilio is back down. We’re continuing to monitor.
Posted 10 months ago. Nov 05, 2018 - 12:32 EST
Monitoring
The last error was seen by our engineers around 11:52 AM EDT, so we're assuming that Twilio is now fully operational. We continue to monitor this situation.
Posted 10 months ago. Nov 05, 2018 - 11:59 EST
Identified
Some calls may fail to go through. We're waiting on Twilio to fix their issue, historically they have had an incredibly reliable service. Updates will follow shortly.
Posted 10 months ago. Nov 05, 2018 - 11:50 EST
This incident affected: Call Handling, Twilio Incoming Phone Calls, Twilio Incoming SIP Calls, Twilio Outgoing Phone Calls, and Twilio Outgoing SIP Calls.