Calls coming to Retreaver from Telnyx through SIP might have issues

Incident Report for Retreaver

Identified

We can not implement a fix for this on our side. Waiting for a resolution from Telnyx
Posted Sep 17, 2025 - 10:39 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 10:38 EDT

Investigating

1. SIP invite is received from publishers using Telnyx.
2. Retreaver responds to the INVITE with 200 OK and continues responding for the next 30 seconds, but Telnyx SIP endpoint does not acknowledge the respons.

This is an early sign that calls might be dropping.

In SIP:

When the caller (UAC) gets a 200 OK (INVITE), it must reply with an ACK.
The callee (UAS) will keep retransmitting 200 OK until it receives that ACK.

We advice clients to get in touch with publishers using Telnyx and platforms using Telnyx (not Retreaver) and to work with them to monitor the traffic.
Posted Sep 17, 2025 - 09:48 EDT
This incident affects: Call Handling.