Investigating an increase in errors from our phone provider (Twilio)

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 15:16 EDT

Monitoring

Twilio has updated their status to "operating normally".

We will continue monitoring over the next hour.
Posted Mar 31, 2025 - 14:40 EDT

Update

Twilio provided information about issues with their service:

'Programmable Voice - 11200 HTTP Retrieval Failures'

https://status.twilio.com/incidents/djx8tktw4z0p
Posted Mar 31, 2025 - 12:06 EDT

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 12:04 EDT

Investigating

We are currently investigating this issue.
Posted Mar 31, 2025 - 12:02 EDT
This incident affected: Twilio Incoming Phone Calls.