Degraded performance on calls

Incident Report for Retreaver

Resolved

Carrier marked as operational
Posted Feb 20, 2026 - 17:44 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2026 - 14:04 EST

Identified

A 'carrier' which is used by another 'call tracking provider' which isn’t Retreaver or Twilio is currently experiencing an incident.
Posted Feb 20, 2026 - 13:36 EST
This incident affected: Call Handling.