Twilio is down, calls are not going through
Incident Report for Retreaver
Resolved
Twilio has given the all clear and calls are going through. We are continuing to monitor and will post a new incident if anything changes.
Posted Mar 22, 2022 - 13:01 EDT
Monitoring
Twilio appears to be back up as calls are going through again. We're waiting on them for confirmation that their issue has been resolved.
Posted Mar 22, 2022 - 12:49 EDT
Investigating
We're currently investigating this issue and are waiting for Twilio to come back up.
Posted Mar 22, 2022 - 12:12 EDT
This incident affected: Call Handling.