RTB reporting delay

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 13:29 EDT

Investigating

RTB Inbound Request Delay
Inbound RTB requests on the dashboard are currently experiencing higher-than-usual delays. The delay is usually under a minute, but it is currently taking significantly longer to update.
Posted Aug 03, 2026 - 10:26 EDT
This incident affected: Real Time Bidding.