Call/RTB Reporting dashboard 2.0 is not loaded

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 09:09 EDT

Monitoring

Incident should be resolved. We are monitoring and confirming.
Posted Apr 23, 2026 - 07:58 EDT

Update

A third party service involved in the reporting are experiencing issues. Working with them on a resolution.
Posted Apr 23, 2026 - 07:19 EDT

Investigating

The issue is currently under investigation. Please use Call 1.0
Posted Apr 23, 2026 - 06:57 EDT
This incident affected: Reporting.