Reports slowdown detected

Incident Report for Retreaver

Resolved

The incident has been resolved the benchmark report ran in a satisfactory amount of time
Posted Jan 22, 2026 - 08:27 EST

Investigating

There has been and instance of a report with degraded performance.
Posted Jan 22, 2026 - 08:06 EST
This incident affected: Reporting.