api.retreaver.com is degraded and might return results slower

Incident Report for Retreaver

Resolved

Improvements have been deployed and clients should not be experiencing this.
Posted Apr 24, 2026 - 09:07 EDT

Investigating

Requests that were send through the night might have returned HTTP 504. If some ingest processes are dependent on this please be advised that these requests will have to be send again once the incident is resolved.
Posted Apr 24, 2026 - 04:55 EDT
This incident affected: API.