Purchasing new local (non toll-free) numbers is temporary disabled for certain area codes.

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted May 09, 2025 - 07:55 EDT

Investigating

Vendors providing the numbers are experiencing difficulties and we've temporary disabled the ability to purchase certain local area codes.
Posted Jan 31, 2025 - 08:28 EST
This incident affected: Site/Account Portal.