Clients using Convoso are experiencing issues

Incident Report for Retreaver

Postmortem

Summary

At the start of the business day, several clients reported issues calls. Our team quickly determined that the issue was isolated to clients using Convoso. Other call traffic was unaffected.

Over the next hour, additional clients—all using Convoso—experienced the same symptoms.
At 9:30 AM EST, Convoso updated their status page indicating a “potential issue.”
At 9:40 AM EST, Convoso updated their status page indicating a “likely issue.”

We continued monitoring independently.

Convoso have acknowledged an incident stating:

Resolution

Convoso resolved the issue on their end. No action was required from our systems.

Posted Apr 04, 2025 - 02:49 EDT

Resolved

Convoso's status health is marked as back up. https://statusgator.com/services/convoso/dialer
Posted Apr 03, 2025 - 12:58 EDT

Identified

Convoso have updated their status page with 'likely issue'.
Waiting for updates from them
Posted Apr 03, 2025 - 09:59 EDT

Investigating

Posted Apr 03, 2025 - 09:48 EDT
This incident affected: Call Handling.