RTB performance degraded

Incident Report for Retreaver

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 14:55 EDT

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 11:32 EDT

Update

Customers are complaining that calls are ending on transfer for no apparent reason
Posted Apr 01, 2025 - 11:31 EDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 11:03 EDT
This incident affected: Call Handling, Webhooks, and Real Time Bidding.